Prefect 2.14.4 : sqlalchemy.exc.OperationalError


I cannot start Prefect server with version 2.14.4 on Rocky Linux 8.6.

Here is my version:

▶ prefect version     
Version:             2.14.4
API version:         0.8.4
Python version:      3.11.2
Git commit:          d2cf30f4
Built:               Thu, Nov 9, 2023 4:48 PM
OS/Arch:             linux/x86_64
Profile:             default
Server type:         ephemeral
  Database:          sqlite
  SQLite version:    3.26.0

I get the following error:

prefect server start
  File "/home/jonathan/Work/virtual_environments/py311_prefect/lib64/python3.11/site-packages/aiosqlite/", line 48, in execute
    await self._execute(self._cursor.execute, sql, parameters)
  File "/home/jonathan/Work/virtual_environments/py311_prefect/lib64/python3.11/site-packages/aiosqlite/", line 40, in _execute
    return await self._conn._execute(fn, *args, **kwargs)
  File "/home/jonathan/Work/virtual_environments/py311_prefect/lib64/python3.11/site-packages/aiosqlite/", line 133, in _execute
    return await future
  File "/home/jonathan/Work/virtual_environments/py311_prefect/lib64/python3.11/site-packages/aiosqlite/", line 106, in run
    result = function()
sqlalchemy.exc.OperationalError: (sqlite3.OperationalError) near "FROM": syntax error
        WITH null_block_type_name_cte AS (SELECT id from block_document where block_type_name is null limit 500)
        UPDATE block_document
        SET block_type_name =
        FROM block_type, null_block_type_name_cte
        WHERE block_document.block_type_id =
        AND =;
(Background on this error at:

Application startup failed. Exiting.
Server stopped!

I tried rm ~/.prefect/prefect.db but it didn’t help, I still have the same error.

Note that version 2.13.0 is working but version 2.14.4 is not working. I suspect a compatibility issue with sqlite3 runtime, but I was not able update the one used by Prefect.

Do you have any idea?


I am having the same exact issue. Have you found any solution?

Hello Reeko,

Unfortunately, I did not have enough time for a deeper investigation. Nobody reacted so far; so I thought it may be due to something specific on my side.

Currently I use version 2.14.0 and it works.

Kind regards.