Worker Git clone not working with HTTP Gitlab repository


I’m trying to deploy my flow using a worker infrastructure instead of an agent, but I get the following error when I run it after deployment:

RuntimeError: Failed to clone repository ‘http://…/prefect.git’ with exit code 128.

in my prefect-yaml file, the pull action is defined as follows and is deployed using a process work-pool.

pull :

  • prefect.deployments.steps.git_clone :
    repository: http://…/prefect.git
    branch : dev
    credentials: “{{prefect.blocks.gitlab-credentials.gitlab}}”

The exact same settings in the storage block used by the agent are working.

What could be the reason for this error?
Is HTTP not supported in the pull action?
Does Prefect Cloud need access to our Gitlab? Only the infrastructure in which the agent and worker are running has it.

Thank you very much!

Hey Sarlan, I’m currently running into the same issue pretty much. Were you able to resolve this? I’m using a serverless push work pool and getting the same error in the container that’s spun up in google cloud run. Despite setting the yaml file to use the creds, I get the same error.


I don’t have any news on this topic. So, I am currently using a workaround with agents for this.

I see that there are similar bugs created on prefect’s github :

Github Credentials for Private Repo not usable with Prefect Projects · Issue #9683 · PrefectHQ/prefect

Deployment run fails when configuring prefect.yaml file pull section with Gitlab credential block · Issue #10282 · PrefectHQ/prefect (