Upgraded my dependencies recently and cannot run my pipeline

I am receiving the following traceback since upgrade prefect. How can i resolve this? I have tried downgrading to prefect 2.10

Traceback (most recent call last):
File “/Users/bradh/Documents/code/ps-data-pipeline/main.py”, line 8, in
from prefect import flow, task
File “/Users/bradh/Library/Caches/pypoetry/virtualenvs/ps-data-pipeline-2xRUdDyL-py3.10/lib/python3.10/site-packages/prefect/init.py”, line 33, in
from prefect.engine import pause_flow_run, resume_flow_run
File “/Users/bradh/Library/Caches/pypoetry/virtualenvs/ps-data-pipeline-2xRUdDyL-py3.10/lib/python3.10/site-packages/prefect/engine.py”, line 31, in
from anyio import start_blocking_portal
ImportError: cannot import name ‘start_blocking_portal’ from ‘anyio’ (/Users/bradh/Library/Caches/pypoetry/virtualenvs/ps-data-pipeline-2xRUdDyL-py3.10/lib/python3.10/site-packages/anyio/init.py)

1 Like

I upgraded prefect from 2.10.18 to 2.12.1 and that resolved it for me.


This worked for me as well. Thank you!

I think this was related to issue #10567, which was resolved shortly after it was opened.

1 Like