Prefect agent failing due to pydantic 2.0.0

We are using prefect==2.3.2. When we install dependency, it install pydantic==2.0.2.
This is because fastapi has upgraded to pydantic>2 but prefect does not and…and prefect dependency does not restrict on upper limit that is pydantic > 2.0.0. When does prefect would updated upper limit of depandancy?

|── pydantic [required: >=1.8.2,!=1.9.1, installed: 2.0.2]
├── fastapi [required: >=0.70, installed: 0.100.0]
├── pydantic [required: >=1.7.4,<3.0.0,!=2.0.1,!=2.0.0,!=1.8.1,!=1.8, installed: 2.0.2]

Hi @maheshmmmec -

You can pin to pydantic<2 in your current environment.
This is fixed in the current version - you can view release notes here:

Thanks. This has fixed the issue.