Database migration - from old to latest 2.11.x

I’ve been running a very old prefect version (0.15.11!) for some time and am finally trying to upgrade to the latest (as of this writing, 2.11.x) version.

We are running on prem with an external postgres instance.

I have been able to run the alembic migrations of our flows to get it up to parity with the latest 1.x release via the server repo:

which takes it up to the alembic migration of:

with a revision id of ac5747fb571c - so the migration from the ancient pre-1.0 to latest 1.x worked well!

However, when trying to make the next jump from 1.x to 2.x and the latest prefect version, I am running into a wall.

When I run prefect server database upgrade pointing to the postgres URL of this now 1.x database running at that revision ID, I get the alembic error of not being able to find that revision ID:

alembic.util.exc.CommandError: Can't locate revision identified by 'ac5747fb571c'

Looking at the current 2.x code’s alembic migrations:

It looks like the alembic migration version set is completely new and distinct from the 1.x migrations, so the error makes sense that it cannot resume because the effective history is different/rewritten.

My question is this, are 1.x flow and task database runs and history migratable at all? and if so, are there instructions that I may have missed to get this updated?